Loading...

Solved windows 7 problem

Discussion in 'Help Desk' started by Ambrosia, Apr 28, 2016.

  1. Ambrosia

    Ambrosia Member

    Joined:
    Apr 24, 2016
    Messages:
    27
    Likes Received:
    17
    Trophy Points:
    3
    Hello everyone .. i have a problem with my windows 7 .. before 2 days i was on xp and daiblo worked fine on full screen mode .. ofc i have black things on the both sides but this is not a problem .. and i decide to install windows 7 now ... but when i run d2 from EuropeBattle.exe nothing happen .. i can see the exe and guard process but the game doesnt open or if the game open its after like 10-15 min on full screen and with messed colors i see green/red/blue etc colors .. when i run the game from Loader everything is ok but its on window mode .. so the question here is can i run diablo 2 on full screen w/o any wrappers and other programs ..even with black tapes on the both sides its not a problem for me .. or i have to play on window mode ..ty :)
     
  2. DiabloDan

    DiabloDan Canadian Forum Legend

    Joined:
    Jan 29, 2016
    Messages:
    134
    Likes Received:
    90
    Trophy Points:
    28
    Hello Ambrosia.

    Diablo 2 is known to have issues with full-screen on operating systems newer than Windows XP. It is best to just play in Windowed mode, unless you want to downgrade back to Windows XP. Keep in mind that the game is 16 years old, so the newer operating systems don't support the old graphics that well.
     
  3. JohnDoe

    JohnDoe Active Member

    Joined:
    Apr 17, 2016
    Messages:
    68
    Likes Received:
    41
    Trophy Points:
    18
    Set the compability options on those exe's

    Diablo II , EuropeBattle , Loader , Game and your MapHack.exe

    Make the run as administrator and compability as Win XP SP3 :) :)

    [​IMG]

    Note !! " Run this program in compability mode for : Win XP SP3 " !! :)

    You can check THIS For additional information :)
     
    Last edited: Apr 29, 2016
  4. dalmadorm

    dalmadorm Member

    Joined:
    Apr 15, 2016
    Messages:
    14
    Likes Received:
    6
    Trophy Points:
    3
    You should use "-w -nofixaspect" parameter after shortcut to your game (for example "D:\Games\Diablo II\Diablo II.exe" -w -nofixaspect").

    You should also tick "Disable desktop composition" in this window:
    [​IMG]
    To fix colors issue. :)

    Only way to have working fullscreen on Windows Vista and newer is using Glide to OpenGL Wrapper. Sorry to say that.

    Hope this will help you.
     
  5. Ambrosia

    Ambrosia Member

    Joined:
    Apr 24, 2016
    Messages:
    27
    Likes Received:
    17
    Trophy Points:
    3
    Ty for help guys .. ill try to play on windowed mode .. its bad choice for pvp player like me but ill try anyway :) btw what about 1.14 patch .. i saw they fix some problems there about graphics and etc .. maybe on this patch fullscreen mode is ok for windows 7/8 etc :) do you think to update the server to 1.14 soon
     
  • Draft saved Draft deleted
    Loading...
    Similar Threads - windows problem
    1. Bahaos
      Replies:
      2
      Views:
      770
    2. ameth
      Replies:
      4
      Views:
      366
    3. ameth
      Replies:
      0
      Views:
      381
    4. PopkaYagodka
      Replies:
      7
      Views:
      948
    5. Brawl
      Replies:
      3
      Views:
      859
    Loading...